{"data":{"id":"ACSD-58108","source":"qpt","sourceRef":"magento/quality-patches@1.1.84","title":"Fixes the issue where the missing joining table name in the original fetching table caused errors with custom module extension SQL in the order grid.","categories":["Order/Checkout","Admin"],"components":["magento/module-sales"],"origin":"adobe-commerce-support","documentation":{"url":"https://experienceleague.adobe.com/en/docs/commerce-operations/tools/quality-patches-tool/patches-available-in-qpt/v1-1-69/acsd-58108-missing-join-table-name-causes-sql-errors-in-order-grid-custom-module-extension","path":"help/tools/quality-patches-tool/patches-available-in-qpt/v1-1-69/acsd-58108-missing-join-table-name-causes-sql-errors-in-order-grid-custom-module-extension.md","blobSha":"a759749ac37c53daef856aaec2890cd567908d63","description":"The missing join table name in the original fetching table causes SQL errors in the order grid when using a custom module extension. This issue occurs because the addFilterToMap function does not work for certain columns after joining the sales_order_item table, resulting in errors while filtering.","stepsToReproduce":"01. Install a 2.4-develop instance. 02. Create a new order. 03. Install a custom module with an SQL extension. 04. Navigate to Admin > Sales > Orders. 05. Apply the Purchase Date filter and wait for the result. 06. Apply Product SKU filter.","introducedInQpt":"1.1.69","createdFor":["2.4.6"],"documentedRange":"2.4.6 - 2.4.7-p6","scheduledFixRelease":"2.5.0"},"files":[{"package":"magento/magento2-base","constraint":">=2.4.7 <2.4.8","path":"patches/os/ACSD-58108_2.4.6.patch","blobSha":"e4e2b0e8e0d23ae55ae56ac70087800cee9fb0cf","url":"https://raw.githubusercontent.com/magento/quality-patches/11d565bdde197b9c7bac859a5698e99098b48457/patches/os/ACSD-58108_2.4.6.patch","thirdParty":false,"modifies":[{"path":"vendor/magento/module-sales/Plugin/Model/ResourceModel/Order/OrderGridCollectionFilter.php","change":"modified","package":"magento/module-sales"},{"path":"vendor/magento/module-sales/etc/adminhtml/di.xml","change":"modified","package":"magento/module-sales"}],"packages":["magento/module-sales"],"hasTests":false,"applicableVersions":{"magento-community":["2.4.7-p10","2.4.7-p9","2.4.7-p8","2.4.7-p7","2.4.7-p6","2.4.7-p5","2.4.7-p4","2.4.7-p3","2.4.7-p2","2.4.7-p1","2.4.7"],"magento-commerce":["2.4.7-p10","2.4.7-p9","2.4.7-p8","2.4.7-p7","2.4.7-p6","2.4.7-p5","2.4.7-p4","2.4.7-p3","2.4.7-p2","2.4.7-p1","2.4.7"],"mage-os":[]},"unknownVersions":[],"requires":[],"replacedWith":"ACP2E-4239","deprecated":false},{"package":"magento/magento2-base","constraint":">=2.4.6 <2.4.7","path":"patches/os/ACSD-58108_2.4.6.patch","blobSha":"e4e2b0e8e0d23ae55ae56ac70087800cee9fb0cf","url":"https://raw.githubusercontent.com/magento/quality-patches/11d565bdde197b9c7bac859a5698e99098b48457/patches/os/ACSD-58108_2.4.6.patch","thirdParty":false,"modifies":[{"path":"vendor/magento/module-sales/Plugin/Model/ResourceModel/Order/OrderGridCollectionFilter.php","change":"modified","package":"magento/module-sales"},{"path":"vendor/magento/module-sales/etc/adminhtml/di.xml","change":"modified","package":"magento/module-sales"}],"packages":["magento/module-sales"],"hasTests":false,"applicableVersions":{"magento-community":["2.4.6-p15","2.4.6-p14","2.4.6-p13","2.4.6-p12","2.4.6-p11","2.4.6-p10","2.4.6-p9","2.4.6-p8","2.4.6-p7","2.4.6-p6","2.4.6-p5","2.4.6-p4","2.4.6-p3","2.4.6-p2","2.4.6-p1","2.4.6"],"magento-commerce":["2.4.6-p15","2.4.6-p14","2.4.6-p13","2.4.6-p12","2.4.6-p11","2.4.6-p10","2.4.6-p9","2.4.6-p8","2.4.6-p7","2.4.6-p6","2.4.6-p5","2.4.6-p4","2.4.6-p3","2.4.6-p2","2.4.6-p1","2.4.6"],"mage-os":[]},"unknownVersions":[],"requires":[],"replacedWith":null,"deprecated":false}],"applicableVersions":{"magento-community":["2.4.7-p10","2.4.7-p9","2.4.7-p8","2.4.7-p7","2.4.7-p6","2.4.7-p5","2.4.7-p4","2.4.7-p3","2.4.7-p2","2.4.7-p1","2.4.7","2.4.6-p15","2.4.6-p14","2.4.6-p13","2.4.6-p12","2.4.6-p11","2.4.6-p10","2.4.6-p9","2.4.6-p8","2.4.6-p7","2.4.6-p6","2.4.6-p5","2.4.6-p4","2.4.6-p3","2.4.6-p2","2.4.6-p1","2.4.6"],"magento-commerce":["2.4.7-p10","2.4.7-p9","2.4.7-p8","2.4.7-p7","2.4.7-p6","2.4.7-p5","2.4.7-p4","2.4.7-p3","2.4.7-p2","2.4.7-p1","2.4.7","2.4.6-p15","2.4.6-p14","2.4.6-p13","2.4.6-p12","2.4.6-p11","2.4.6-p10","2.4.6-p9","2.4.6-p8","2.4.6-p7","2.4.6-p6","2.4.6-p5","2.4.6-p4","2.4.6-p3","2.4.6-p2","2.4.6-p1","2.4.6"],"mage-os":[]},"conditions":{"and":[{"type":"log","path":"var/log/exception.log","match":"report.CRITICAL: PDOException: SQLSTATE[23000]: Integrity constraint violation: 1052 Column 'created_at' in where clause is ambiguous in */DB/Statement/Pdo/Mysql.php"}]},"requirements":null},"_documentation":"https://magento.watch/api","_description":"Quality patch ACSD-58108 details"}