{"data":{"id":"ACSD-58739","source":"qpt","sourceRef":"magento/quality-patches@1.1.84","title":"Fixes the issue where partial reindexing throws an error. It now works correctly with big change log and when the Slave db connection with synchronous_replication is configured.","categories":["Other"],"components":["magento/framework"],"origin":"adobe-commerce-support","documentation":{"url":"https://experienceleague.adobe.com/en/docs/commerce-operations/tools/quality-patches-tool/patches-available-in-qpt/v1-1-49/acsd-58739-partial-reindexing-throws-an-error","path":"help/tools/quality-patches-tool/patches-available-in-qpt/v1-1-49/acsd-58739-partial-reindexing-throws-an-error.md","blobSha":"91475aee73c51f82feed2207a1d815e3ff2af63a","description":"Partial reindexing throws an error.","stepsToReproduce":"1. Add slave connection settings to the app/etc/env.php. 1. Generate up to 10000 products and execute the following command: bin/magento index:reindex 1. Add generated product IDs into catalogsearch_fulltext_cl DB table. insert into catalogsearch_fulltext_cl (entity_id) select entity_id from catalog_product_entity; 1. Execute the following command to trigger the partial reindex: bin/magento cron:run --group=index --bootstrap=standaloneProcessStarted=1 1. Check the var/log/support_report.log file.","introducedInQpt":"1.1.49","createdFor":["2.4.7"],"documentedRange":"2.4.7 - 2.4.8","scheduledFixRelease":"2.4.8"},"files":[{"package":"magento/magento2-base","constraint":">=2.4.7 <2.4.8","path":"patches/os/ACSD-58739_2.4.7.patch","blobSha":"a1fcecfbe171fc83eec767c377efe6f0d7127bdd","url":"https://raw.githubusercontent.com/magento/quality-patches/11d565bdde197b9c7bac859a5698e99098b48457/patches/os/ACSD-58739_2.4.7.patch","thirdParty":false,"modifies":[{"path":"vendor/magento/framework/Mview/View/ChangelogBatchWalker.php","change":"modified","package":"magento/framework"},{"path":"vendor/magento/framework/Mview/View/ChangelogBatchWalker/IdsTableBuilder.php","change":"modified","package":"magento/framework"}],"packages":["magento/framework"],"hasTests":false,"applicableVersions":{"magento-community":["2.4.7-p10","2.4.7-p9","2.4.7-p8","2.4.7-p7","2.4.7-p6","2.4.7-p5","2.4.7-p4","2.4.7-p3","2.4.7-p2","2.4.7-p1","2.4.7"],"magento-commerce":["2.4.7-p10","2.4.7-p9","2.4.7-p8","2.4.7-p7","2.4.7-p6","2.4.7-p5","2.4.7-p4","2.4.7-p3","2.4.7-p2","2.4.7-p1","2.4.7"],"mage-os":[]},"unknownVersions":[],"requires":[],"replacedWith":"ACP2E-3705","deprecated":false}],"applicableVersions":{"magento-community":["2.4.7-p10","2.4.7-p9","2.4.7-p8","2.4.7-p7","2.4.7-p6","2.4.7-p5","2.4.7-p4","2.4.7-p3","2.4.7-p2","2.4.7-p1","2.4.7"],"magento-commerce":["2.4.7-p10","2.4.7-p9","2.4.7-p8","2.4.7-p7","2.4.7-p6","2.4.7-p5","2.4.7-p4","2.4.7-p3","2.4.7-p2","2.4.7-p1","2.4.7"],"mage-os":[]},"conditions":null,"requirements":null},"_documentation":"https://magento.watch/api","_description":"Quality patch ACSD-58739 details"}