{"data":{"id":"ACSD-67091","source":"qpt","sourceRef":"magento/quality-patches@1.1.84","title":"Fixes the maximum writeset size error to ensure catalog rule product index cleanup by implementing two deletion strategies based on data volume.","categories":["Price/Tax","Catalog/Product","Performance","Cron"],"components":["magento/module-catalog-rule"],"origin":"adobe-commerce-support","documentation":{"url":"https://experienceleague.adobe.com/en/docs/commerce-operations/tools/quality-patches-tool/patches-available-in-qpt/v1-1-76/acsd-67091","path":"help/tools/quality-patches-tool/patches-available-in-qpt/v1-1-76/acsd-67091.md","blobSha":"e0ba15560b1ae1473c40dc9a03737c6c330ad239","description":"Catalog rule product index cleanup fails with a maximum writeset size error during large deletions.","stepsToReproduce":"1. Run reindexing to generate data and populate the catalogrule_product table using the following command: bin/magento indexer:reindex catalogrule_product 1. Make multiple catalog changes, and then run reindexing again. 1. Observe that the catalogrule_product table is cleared using a single delete operation.","introducedInQpt":"1.1.76","createdFor":["2.4.8"],"documentedRange":"2.4.8 - 2.4.8-p3","scheduledFixRelease":"2.4.9"},"files":[{"package":"magento/magento2-base","constraint":">=2.4.8 <2.4.9","path":"patches/os/ACSD-67091_2.4.8.patch","blobSha":"e045a2ef270476bd212ed47a7d3d504835cc0f77","url":"https://raw.githubusercontent.com/magento/quality-patches/11d565bdde197b9c7bac859a5698e99098b48457/patches/os/ACSD-67091_2.4.8.patch","thirdParty":false,"modifies":[{"path":"vendor/magento/module-catalog-rule/Model/Indexer/IndexBuilder.php","change":"modified","package":"magento/module-catalog-rule"}],"packages":["magento/module-catalog-rule"],"hasTests":false,"applicableVersions":{"magento-community":["2.4.8-p5","2.4.8-p4","2.4.8-p3","2.4.8-p2","2.4.8-p1","2.4.8"],"magento-commerce":["2.4.8-p5","2.4.8-p4","2.4.8-p3","2.4.8-p2","2.4.8-p1","2.4.8"],"mage-os":[]},"unknownVersions":[],"requires":[],"replacedWith":null,"deprecated":false}],"applicableVersions":{"magento-community":["2.4.8-p5","2.4.8-p4","2.4.8-p3","2.4.8-p2","2.4.8-p1","2.4.8"],"magento-commerce":["2.4.8-p5","2.4.8-p4","2.4.8-p3","2.4.8-p2","2.4.8-p1","2.4.8"],"mage-os":[]},"conditions":null,"requirements":null},"_documentation":"https://magento.watch/api","_description":"Quality patch ACSD-67091 details"}