{"data":{"id":"ACSD-68793","source":"qpt","sourceRef":"magento/quality-patches@1.1.84","title":"Fixes an issue where valid products were incorrectly rejected when assigning them to a shared catalog.","categories":["B2B"],"components":["magento/module-shared-catalog"],"origin":"adobe-commerce-support","documentation":{"url":"https://experienceleague.adobe.com/en/docs/commerce-operations/tools/quality-patches-tool/patches-available-in-qpt/v1-1-75/acsd-68793","path":"help/tools/quality-patches-tool/patches-available-in-qpt/v1-1-75/acsd-68793.md","blobSha":"0b2b96e1b5d438d0a37c9b4b4c25f10460a04b11","description":"Valid products are incorrectly rejected during shared catalog assignment through the REST API, and the system returns an error stating that existing SKUs don’t exist.","stepsToReproduce":"1. Create several products. 1. In the Admin sidebar, navigate to Catalog > Shared Catalog. 1. Click Add Shared Catalog and create a shared catalog. 1. Assign all products to the shared catalog you created. 1. Send a REST API request to /rest/V1/sharedCatalog/3/assignProducts with the list of SKUs for existing products to assign them to the shared catalog.","introducedInQpt":"1.1.75","createdFor":["1.5.2-p1"],"documentedRange":"1.5.1 - 1.5.2-p3","scheduledFixRelease":"1.5.3"},"files":[{"package":"magento/magento2-b2b-base","constraint":">=1.5.1 <1.5.3","path":"patches/commerce/ACSD-68793_1.5.2.patch","blobSha":"dd6cc07ccb65f3448f59cedcae5e9c951347a235","url":"https://raw.githubusercontent.com/magento/quality-patches/11d565bdde197b9c7bac859a5698e99098b48457/patches/commerce/ACSD-68793_1.5.2.patch","thirdParty":false,"modifies":[{"path":"vendor/magento/module-shared-catalog/Model/ProductManagement.php","change":"modified","package":"magento/module-shared-catalog"}],"packages":["magento/module-shared-catalog"],"hasTests":false,"applicableVersions":{"magento-community":[],"magento-commerce":["2.4.8-p4","2.4.8-p3","2.4.8-p2","2.4.8-p1","2.4.8","2.4.7-p10","2.4.7-p9","2.4.7-p8","2.4.7-p7","2.4.7-p6","2.4.7-p5","2.4.7-p4","2.4.6-p15","2.4.6-p14","2.4.6-p13","2.4.6-p12","2.4.6-p11","2.4.6-p10","2.4.6-p9"],"mage-os":[]},"unknownVersions":[],"requires":[],"replacedWith":null,"deprecated":false}],"applicableVersions":{"magento-community":[],"magento-commerce":["2.4.8-p4","2.4.8-p3","2.4.8-p2","2.4.8-p1","2.4.8","2.4.7-p10","2.4.7-p9","2.4.7-p8","2.4.7-p7","2.4.7-p6","2.4.7-p5","2.4.7-p4","2.4.6-p15","2.4.6-p14","2.4.6-p13","2.4.6-p12","2.4.6-p11","2.4.6-p10","2.4.6-p9"],"mage-os":[]},"conditions":null,"requirements":null},"_documentation":"https://magento.watch/api","_description":"Quality patch ACSD-68793 details"}