PATCHES FOR A MODULE
Quality patches and upstream fixes for magento/framework
81 Adobe quality patches and 39 community upstream fixes touch magento/framework.
Quality patches (81)
| Id | Symptom | Modules |
|---|---|---|
| AC-10737 | The bin/magento setup:db:status command does not recognize JSON column types and incorrectly reports that the declarative schema is not up to date | magento/framework |
| AC-17975 | Multiple PHP 8.5 compatibility issues affecting Admin workflows, checkout authentication, CAPTCHA processing, category management, configuration pages, and command-line operations in certain PHP environments | magento/framework, magento/module-captcha, magento/module-catalog |
| ACP2E-3705 | The indexer_update_all_views cron execution fails when MAGE_INDEXER_THREADS_COUNT is set to a value greater than 2, specifically affecting the Customer Segments indexer with B2B enabled | magento/framework, magento/module-indexer, magento/module-catalog-permissions |
| ACP2E-4194 | Issue where GraphQL requests with unknown filter names cause PHP exception logs | magento/framework, magento/module-graph-ql, magento/theme-frontend-blank, magento/theme-frontend-luma |
| ACP2E-4402 | Issue where products created as disabled were not added back to related Target Rule results after being enabled | app/etc, magento/framework, magento/module-indexer, magento/module-catalog-staging, magento/module-staging, magento/module-target-rule |
| ACP2E-4448 | L2 cache, local cache, stale cache, and Redis became unsynchronized when Redis was unavailable | magento/framework |
| ACP2E-4732 | Partial indexation stops for customers with a large number of updates after the version_id column in the changelog table reaches its maximum value | magento/framework, magento/module-indexer |
| ACP2E-4815 | Multiple GraphQL issues that caused PHP exceptions in logs, correct association of orders with customer accounts created post-order via GraphQL, and alignment of responses with GraphQL over HTTP specifications | magento/module-graph-ql, magento/framework, magento/module-customer-graph-ql, magento/module-quote-graph-ql, magento/theme-frontend-blank, magento/theme-frontend-luma |
| ACP2E-4908 | Large catalogs could cause excessive memory use in Redis or Valkey because separate layout cache entries were created for each product in each store view | magento/framework |
| ACP2E-4913 | Shipping and invoicing operations fail due to a deadlock | app/etc, magento/framework, magento/module-developer, magento/module-sales |
| ACP2E-5027 | Indexers remain stuck in a loop and reindexing does not complete when file locking is enabled | magento/framework |
| ACP2E-5122 | Handled errors from GraphQL requests for the shopping cart are incorrectly recorded in exception logs as application errors | magento/framework |
| ACP2E-5183 | Static content deployment fails on PHP 8.5 while compiling a LESS file that uses the @magento_import directive | magento/framework |
| ACSD-46404 | The admin user cannot log in after upgrading to 2.4.4 | magento/framework |
| ACSD-46938 | Performance degradation during DB trigger recreation in setup:upgrade | magento/framework |
| ACSD-46988 | GraphQL currency API request returns null values for a custom currency | magento/framework, magento/module-bundle, magento/module-configurable-product, magento/module-quote, magento/module-reports, magento/module-sales |
| ACSD-47937 | Customers are not getting product price drop email for subsequent product price changes | b/c, magento/framework, magento/framework-amqp, magento/module-elasticsearch, magento/module-product-alert |
| ACSD-49970-V3 | Incorrect handling of GraphQL errors when New Relic reporting is turned on | magento/framework, magento/module-graph-ql |
| ACSD-50336 | Product alert emails are not sent when a product is back in stock or the price is changed | magento/framework, magento/module-elasticsearch, magento/module-product-alert |
| ACSD-50478 | JS issue for the rollback action in the Backups grid and the database rollback command for a case when the DB dump contains triggers and a delimiter SQL command | magento/framework, magento/module-backend, magento/module-backup |
| ACSD-51114 | Random products disappeared from large catalogs when asynchronous indexing is enabled | magento/framework, magento/module-eav |
| ACSD-51431 | The indexer status is Working even though there are no entries in the changelog | magento/framework |
| ACSD-51528 | The different behaviors on snake_case formatting | magento/framework |
| ACSD-51846 | An "Internal Error" occurs as all levels of REST API payload are not validated | magento/framework, magento/module-elasticsearch |
| ACSD-51892 | There is a performance issue where the config files load multiple times | magento/framework |
| ACSD-52657 | Minicart is not updated on the secondary storeview that uses a subdomain | app/etc, magento/framework, magento/module-customer, magento/module-page-cache |
| ACSD-53098 | Products assigned to a shared catalog via API do not show up on the frontend after the partial indexer executes the cron job, followed by the consumer cron | app/etc, magento/framework, magento/module-catalog, magento/module-indexer, magento/module-catalog-permissions, magento/module-shared-catalog |
| ACSD-53098-V2 | Products assigned to a shared catalog are not appearing on the storefront when a partial index is executed | app/etc, magento/framework, magento/module-catalog, magento/module-indexer, magento/module-catalog-permissions, magento/module-shared-catalog |
| ACSD-53583 | Partial reindex takes more time than full reindex | magento/framework, magento/module-catalog-search, magento/module-elasticsearch |
| ACSD-53845 | MySQL connection times out when consumer max_messages = 0 | magento/framework |
| ACSD-54095 | Incorrect handling of GraphQL errors when New Relic reporting is turned on | magento/framework, magento/module-graph-ql |
| ACSD-54111 | The product thumbnail image is not showing | magento/framework |
| ACSD-54965-V2 | The Visual Merchandising grid does not display the correct stock when a product is assigned to custom stock only | magento/framework, magento/module-visual-merchandiser, magento/module-inventory-visual-merchandiser |
| ACSD-55031 | The Type "mixed" cannot be nullable error occurs during compilation | magento/framework |
| ACSD-56741 | An error message Trying to access array offset on value of type null appears during setup:upgrade due to a custom MySQL trigger in the database unrelated to indexation and MView | magento/framework |
| ACSD-57477 | Sales rule processing causes slow performance on cart-related requests if you send the parameters as GraphQL variables | magento/framework, magento/module-quote, magento/module-quote-graph-ql, magento/module-sales-rule |
| ACSD-58141 | PHPSESSID regenerates on POST requests for a logged-in customer with the L2 Redis cache enabled | magento/framework |
| ACSD-58739 | Partial reindexing throws an error | magento/framework |
| ACSD-59280 | ReflectionUnionType::getName() error during 2.4.4-pX installation | magento/framework |
| ACSD-60816 | New Relic browser monitoring scripts injected by the APM agent are not compliant with CSP | magento/framework, magento/module-backend, magento/module-catalog, magento/module-new-relic-reporting, magento/module-theme |
| ACSD-60989 | Modifying a column with a foreign key via declarative schema on MariaDB fails due to foreign key constraint errors during setup upgrade | magento/framework |
| ACSD-61103 | The failure count in the customer_entity table does not reset to zero even after a customer logs in successfully through API endpoints | magento/framework, magento/module-customer, magento/module-customer-graph-ql, magento/module-integration |
| ACSD-61366 | The bin/magento setup:static-content:deploy --jobs 4 command encounters multiple job failures with the Port must be configured within the host parameter error, despite specifying the port for the DB connection | magento/framework |
| ACSD-62332 | The product listing GraphQL query is limited to a total_count of 10,000 products and where Live Search sets the current page to 1 instead of page 2 in the search criteria when queried via GraphQL | magento/framework, magento/module-catalog-graph-ql, magento/module-catalog-search, magento/module-elasticsearch, magento/module-elasticsearch-7, magento/module-graph-ql, magento/module-open-search, magento/module-elasticsearch-catalog-permissions |
| ACSD-62979 | Using the incorrect Store ID in the GraphQL header causes a fatal memory error | magento/framework, magento/module-store |
| ACSD-63242 | Product import is slow when catalog products with more than 10,000 entries are added | magento/framework |
| ACSD-63286 | When products are assigned to a shared catalog via API, they don't appear on the frontend after the partial indexer and consumer cron jobs run | app/etc, magento/framework, magento/module-catalog, magento/module-indexer, magento/module-catalog-permissions, magento/module-catalog-staging, magento/module-elasticsearch-catalog-permissions, magento/module-staging, magento/module-shared-catalog |
| ACSD-63326 | Admins are redirected to a page with a broken layout after successfully placing an order for a customer from the backend | magento/framework |
| ACSD-63687 | Incorrect prices display because Redis cache cleanup fails | app/etc, magento/framework, setup/src |
| ACSD-64113 | Errors occur in the admin when uploading images with a relatively small width compared to their height (or vice versa) via the Media Gallery | magento/framework |
| ACSD-64149 | A customer segment with a date range condition can be saved when only one of the dates is edited | magento/framework |
| ACSD-64532 | ENV variable set to false is treated as a string false instead of a BOOLEAN FALSE | magento/framework |
| ACSD-65787 | The SchemaBuilder class crashes during schema creation or updates due to an undefined array key "column" when processing table data | magento/framework |
| ACSD-66153 | A page returns a 500 error because of a cached incorrect layout structure | magento/framework |
| ACSD-66404 | Cron job not clearing changelog tables and causing Galera Cluster issues in case of large amount of data in these tables | magento/framework, magento/module-indexer, magento/module-theme, setup/src |
| ACSD-67659 | The translated exception message is used to map the error code for GraphQL requests, causing known errors to return an UNDEFINED error code instead of the correct one | magento/module-async-order-graph-ql, magento/framework, magento/module-graph-ql, magento/module-quote-graph-ql |
| ACSD-67686 | A "Syntax Error: Unexpected <EOF>" error occurs when submitting an empty GraphQL request | magento/framework, magento/module-graph-ql |
| ACSD-67908 | Merged JavaScript files fail to generate correctly in multi-store setups, leading to corrupted files and storefront errors | magento/framework |
| ACSD-67941 | GraphQL requests that include unknown filter names trigger PHP exception logs | magento/framework, magento/module-customer-graph-ql, magento/module-graph-ql, magento/theme-frontend-blank, magento/theme-frontend-luma |
| ACSD-68206 | The issue occurs when the GraphQL Application server uses the Rate Limiting feature with the PHP Redis extension installed, resulting in a broken rate limit functionality | magento/framework |
| ACSD-68759 | The Create an Account page fails to load when the Locale is set to Arabic (Saudi Arabia) and the Date of Birth attribute is visible on the storefront, resulting in a TypeError | magento/framework, magento/module-customer |
| ACSD-68925 | Previously, invalid GraphQL requests generated internal server errors, instead of the correct 4XX responses defined by the GraphQL over HTTP specification | magento/framework, magento/module-graph-ql, magento/theme-frontend-blank, magento/theme-frontend-luma |
| ACSD-69086 | Installation of the Adobe Commerce instance fails when using MariaDB 10.11 | magento/framework, magento/module-indexer |
| ACSD-69494 | The async refund requests with the is_online parameter aren't processed correctly | magento/framework, magento/module-webapi-async |
| MDVA-12304 | Increases the maximum number of cookies from 50 to 200 | magento/framework |
| MDVA-13203 | The 'Integrity constrain violation search_tmp_* table' error appears after a full reindex | magento/framework |
| MDVA-23426 | Notification emails sent by Magento contain a blank body with content being added as attachment | magento/framework |
| MDVA-25602 | PayPal Payflow Pro payment method and treating cookies as SameSite=Lax by default in the Chrome 80 browser and API response redirect to customer login page | magento/framework, magento/module-payment, magento/module-paypal, magento/module-website-restriction |
| MDVA-27825 | Exporting of big amounts of data failed because of memory leak | magento/framework, magento/module-eav |
| MDVA-28993 | Implements the "Minimum should match" functionality and partial search for Elasticsearch engine | magento/framework, magento/module-catalog-graph-ql, magento/module-catalog-search, magento/module-elasticsearch, magento/module-elasticsearch-6 |
| MDVA-30102 | Redis cache grows up quickly since layout caches don't have TTL | magento/framework |
| MDVA-30195 | Cron jobs fail if database name is too long, resulting in categories not being updated on the storefront | magento/framework |
| MDVA-30862 | Incorrect order date is printed on the PDF invoice | magento/framework |
| MDVA-31343 | The removed body class "page-layout-category-full-width" when a category is scheduled | magento/framework, magento/module-catalog-staging |
| MDVA-34879 | Exporting of big amounts of data failed because of memory leak | magento/framework, magento/module-customer-import-export, magento/module-eav |
| MDVA-34948 | The website gets slow, which hampers operations | magento/framework, magento/module-message-queue |
| MDVA-38308 | Issues related to adding Vimeo videos to products | magento/framework |
| MDVA-39305-V2 | A form can be submitted before Google ReCAPTCHA fully loads | magento/module-re-captcha-contact, magento/module-re-captcha-customer, magento/module-re-captcha-frontend-ui, magento/module-re-captcha-newsletter, magento/module-re-captcha-review, magento/module-re-captcha-send-friend, magento/module-re-captcha-ui, magento/module-contact, magento/module-customer, magento/module-newsletter, magento/module-review, magento/module-send-friend, magento/framework, magento/module-customer-custom-attributes, magento/module-invitation |
| MDVA-39305-V3 | magento/module-re-captcha-customer, magento/module-re-captcha-frontend-ui, magento/module-re-captcha-contact, magento/module-re-captcha-newsletter, magento/module-re-captcha-review, magento/module-re-captcha-send-friend, magento/module-re-captcha-ui, magento/module-customer, magento/framework, magento/module-contact, magento/module-newsletter, magento/module-review, magento/module-send-friend, magento/module-customer-custom-attributes, magento/module-invitation | |
| MDVA-40550 | Missing products on the storefront during reindexing | magento/framework, magento/module-catalog, magento/module-indexer |
| MDVA-44188 | Unable to send emails to email IDs that contain .- in their user name | magento/framework |
Upstream fixes (39)
| Id | Symptom | Modules |
|---|---|---|
| magento2-25859 | Drops the indexer changelog table when an index switches to update on save | magento/framework, magento/module-indexer |
| magento2-30070 | Custom attributes missing on the current account navigation link | magento/framework |
| magento2-32919 | Removes double spaces between attributes in link and script tags | magento/framework |
| magento2-32922 | Excludes styles of disabled modules from compiled CSS when configured | magento/framework |
| magento2-35174 | Sets utf8mb4 as default table charset for the 10.6 and mysql_8_29 keys | magento/framework |
| magento2-35580 | Renders critical CSS before assets and adds a critical head block | magento/framework, magento/module-catalog, magento/module-theme |
| magento2-37362 | Make ImageMagick Adapter compatible with php8 (Implicit conversion from float to int) | magento/framework |
| magento2-37550 | JoinProcessor join definitions are only applied the first time per request | magento/framework |
| magento2-37570 | Extract handlers load layout XML without an exception for invalid XML | magento/framework |
| magento2-37613 | HTTP Curl Adapter sets headers in associative array format | magento/framework |
| magento2-37712 | Exception handling inconsistency between developer and production modes | magento/framework |
| magento2-37842 | Difference in less compilation between php & nodejs library (grunt) with complicated `calc` expressions | magento/framework, magento/magento2-base |
| magento2-38239 | Setup:upgrade errors when an applied patch is changed to a new class name | magento/framework |
| magento2-38270 | Duplicate cache fpc for same page with same query | magento/framework, magento/module-page-cache |
| magento2-38364 | Calendar warning when the ICU locale data has no AmPmMarkers | magento/framework |
| magento2-38527 | LoggerProxy modifying a read-only ObjectManager property in __wakeup | magento/framework |
| magento2-38729 | PHP fatal error from a missing getRetries in the Redis session Config | magento/framework |
| magento2-38794 | An infinite loop when a di.xml virtual type refers to itself | magento/framework |
| magento2-38842 | Static content deploy failing when the database host includes a port | magento/framework |
| magento2-38922 | "Area code not set" during static content deploy with CSP enabled | magento/framework |
| magento2-39084 | Call to undefined function ftp_connect() in FTP CSV import | magento/framework |
| magento2-39099 | The built-in FPC keeps marketing GET parameters | magento/framework, magento/module-page-cache |
| magento2-39372 | Ever growing var/locks directory with file based locking | magento/framework, magento/module-backend |
| magento2-39669 | Minicart update with a decimal qty: 0.7 is expected, 1 is in cart | magento/framework, magento/module-checkout |
| magento2-39690 | Special price with a time in price_to is valid one day longer | magento/framework, magento/module-bundle, magento/module-catalog |
| magento2-39799 | Adds table and column to the SchemaBuilder Undefined array key type error | magento/framework |
| magento2-39941 | Attribute option label 'is already exists' response is now 'already exists' | magento/framework, magento/module-catalog-import-export, magento/module-downloadable-import-export, magento/module-eav |
| magento2-40063 | Bin/magento hiding the real error when a command class fails to load | magento/framework |
| magento2-40081 | Log noise for plugins disabled in di.xml whose original module was removed | magento/framework |
| magento2-40201 | Escaper checking preg_replace results for false instead of null | magento/framework |
| magento2-40242 | Db_schema.xml comment="" making setup:db:status always report changes | magento/framework |
| magento2-40349 | Built-in FPC keys still containing marketing params after stripping | magento/framework, magento/module-page-cache |
| magento2-40538 | GLOB_BRACE usage that breaks bin/magento commands on non-GNU Linux systems | magento/framework |
| magento2-40546 | Inserts indexer changed entries in batches instead of one bulk insert | magento/framework |
| magento2-40581 | URL keys that lose Ã, ã and Ê when a product name is transliterated | magento/framework |
| magento2-40582 | Setup:db:status reporting changes for unsigned doubles without precision | magento/framework |
| magento2-40643 | Setup:upgrade recreating every indexer trigger on each run | magento/framework, magento/module-indexer |
| magento2-40880 | Di.xml array items being replaced when a later module uses the item name 0 | magento/framework |
| magento2-40889 | HTTP 500 when editing the Global design configuration scope on PHP 8.5 | magento/framework |
See also: search patches · patches by module · methodology
